YaCy-Bugtracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000007YaCy[All Projects] Generalpublic2011-03-21 14:302012-01-23 22:03
ReporterQuix0r 
Assigned Tof1ori 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
ETAnone 
PlatformDebian UnstableOSLinuxOS Version2.6.37
Product Version 
Target VersionFixed in VersionYaCy 1.0 
Summary0000007: Debian-Paket schliesst Konfiguration nicht ab, wenn Admin-Passwort vergeben wurde
DescriptionDas aktuell von Florian gewartete Debian-Paket "haengt" beim Konfigurieren des Paketes wenn zuvor ein Admin-Passwort eingegeben wird (in DebConf), wird das Admin-Passwort leer gelassen, schliesst die Einrichtung (postinstall) des Debian-Paketes ab und YaCy startet.
Additional InformationIch habe es (hoffentlich) auf eine fehlerhafte Zeile in dem postinstall-Script zurueckfuehren koennen. Dort wird eine rudimentaere Konfigurationsdatei geschrieben, wo ein Tippfehler vorliegt, es wird zweimal der Parameter Xmx an das Java-Programm "Base64Order" uebergeben, es sollte aber nur einmal uebergeben werden und einmal Xms uebergeben werden, was wegen des Tippfehlers nicht geschieht.
Tagsadmin-passwort, bug, deb-paket, debconf
Attached Filesbz2 file icon debian-scripts.patch.bz2 [^] (861 bytes) 2011-03-21 16:06

- Relationships

-  Notes
(0000008)
Quix0r (updater)
2011-03-21 16:12

Mit dem hochgelandenen Patch (ohne dem wuerde es viel frueher abbrechen) erhalte ich beim Bauen des Debian-Paketes folgendes:
     [exec] dpkg-gencontrol: warning: package yacy: unused substitution variable ${misc:Depends}
     
[exec] dh_md5sums
     [exec] dh_builddeb
     [exec] dpkg-deb: building package `yacy' in `../yacy_0.99svn7614_all.deb'.
     [exec]  dpkg-genchanges -b >../yacy_0.99svn7614_amd64.changes
     [exec] dpkg-genchanges: binary-only upload - not including any source code
     [exec]  dpkg-source --after-build yacy
     [exec] dpkg-buildpackage: binary only upload (no source included)
(0000009)
f1ori (developer)
2011-03-21 20:49

Log muss shutdown beendet werden. Die von den Debian Konfigurationsskript verwendete Klasse Base64 ruft dies aber nicht in der main-Methode auf.

@Quix0r: Hab die Änderung von Build-Depends aktualisiert. Die anderen Sachen halte ich nicht für notwendig. Bei mir Kompiliert das Packet problemlos.

- Issue History
Date Modified Username Field Change
2011-03-21 14:30 Quix0r New Issue
2011-03-21 14:31 Quix0r Tag Attached: admin-passwort
2011-03-21 14:31 Quix0r Tag Attached: bug
2011-03-21 14:31 Quix0r Tag Attached: debconf
2011-03-21 14:31 Quix0r Tag Attached: debn
2011-03-21 14:31 Quix0r Tag Detached: debn
2011-03-21 14:31 Quix0r Tag Attached: deb-paket
2011-03-21 15:53 f1ori Assigned To => f1ori
2011-03-21 15:53 f1ori Status new => assigned
2011-03-21 16:06 Quix0r File Added: debian-scripts.patch.bz2
2011-03-21 16:12 Quix0r Note Added: 0000008
2011-03-21 20:49 f1ori Note Added: 0000009
2011-03-21 20:49 f1ori Status assigned => resolved
2011-03-21 20:49 f1ori Fixed in Version => YaCy 1.0
2011-03-21 20:49 f1ori Resolution open => fixed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker