YaCy-Bugtracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000594YaCyWishlist - Wunschlistepublic2015-07-11 15:102015-09-03 23:34
ReporterDavide 
Assigned ToBuBu 
PrioritynormalSeveritytrivialReproducibilityN/A
StatusresolvedResolutionfixed 
ETAnone 
PlatformOSOS Version
Product VersionYaCy 1.8 
Target VersionFixed in Version 
Summary0000594: Image search returns 1x1 pixel images
DescriptionThe image search does not filter useless 1x1 pixel images and alike, such as 20x1, 50x2, etc.

These images only pollute search results.
Moreover, when you click on them to open their preview from yacysearch.html, such previews are impossible to close as you'd need to click exactly upon that 1x1 pixel.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001095)
BuBu (developer)
2015-08-30 02:23

improved with commit https://github.com/yacy/yacy_search_server/commit/19f1308bf09172d2be66c58289d52ba2b2c0cf9d [^]
(v1.83/9322)
(0001096)
Davide (reporter)
2015-08-30 11:03

Thanks Bubu.

I wouldn't mark this bug as fixed, as it's only marginally worked around.
(0001097)
BuBu (developer)
2015-09-01 23:28

Hm,
improved workaround a little bit more.
https://github.com/yacy/yacy_search_server/commit/dba7f15073b0114e0b56363db01de2ffbbd5ebcb [^]

Don't see how it gets better than this in near future.
(0001100)
Davide (reporter)
2015-09-02 01:30

Thanks Bubu for the extra code ;)

The 16 pixels filter is a good concept for general usage, and fits my specific usage too.
What are the circumstances under which image width or height remain unknown, and are thus not filtered off?
(0001102)
BuBu (developer)
2015-09-03 23:34

this is while it's only a improvement (not a complete fix, eg. prereading every image) because many situation with unknown size

- image_size is not a mandatory index field (if switched off... no filter at all)
- if java api doesn't deliver size (rare)
- remote search results got over YaCy traditional RWI communication (the delivered results don't include picture size)
- remote (Solr) search result from peer that has switched off images_size

- Issue History
Date Modified Username Field Change
2015-07-11 15:10 Davide New Issue
2015-08-30 02:23 BuBu Note Added: 0001095
2015-08-30 02:23 BuBu Status new => resolved
2015-08-30 02:23 BuBu Resolution open => fixed
2015-08-30 02:23 BuBu Assigned To => BuBu
2015-08-30 11:03 Davide Note Added: 0001096
2015-08-30 11:03 Davide Status resolved => feedback
2015-08-30 11:03 Davide Resolution fixed => reopened
2015-09-01 23:28 BuBu Note Added: 0001097
2015-09-02 01:30 Davide Note Added: 0001100
2015-09-02 01:30 Davide Status feedback => assigned
2015-09-03 23:34 BuBu Note Added: 0001102
2015-09-03 23:34 BuBu Status assigned => resolved
2015-09-03 23:34 BuBu Resolution reopened => fixed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker