YaCy-Bugtracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000514YaCy[All Projects] Generalpublic2014-12-15 01:312015-01-12 01:09
Reportersmokingwheels 
Assigned ToOrbiter 
PrioritynormalSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
ETAnone 
Platformx86OSDebian 7 WheezyOS Version7.7.0
Product VersionYaCy 1.8 
Target VersionFixed in Version 
Summary0000514: Exception in Thread "Main" when installing. Yacy fails to install
DescriptionI downloaded Debian Wheezy 7.7.0 ISO and installed it, in Virtual Box on a Host OS of Windows.
I used novice settings for Debian.

I ran my script off my robot keyboard.
The package of Yacy fails to decompress by the looks.
Java Version 7 rev 51. From my memory.
Steps To Reproduceapt-get install yacy
Additional InformationUnpacking yacy (from .../yacy_1.81.9268_all.deb) ...
Setting up yacy (1.81.9268) ...
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/yacy/cora/order/Base64Order : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: net.yacy.cora.order.Base64Order. Program will exit.
dpkg: error processing yacy (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 yacy
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@debian:/home/yacy#



TagsNo tags attached.
Attached Files7z file icon Yacy.7z [^] (136,473 bytes) 2014-12-15 01:31

- Relationships

-  Notes
(0000986)
Orbiter (manager)
2015-01-12 01:09

"Unsupported major.minor version 51.0" means that you probably have a too low java version. Please upgrade your jvm

- Issue History
Date Modified Username Field Change
2014-12-15 01:31 smokingwheels New Issue
2014-12-15 01:31 smokingwheels File Added: Yacy.7z
2015-01-12 01:09 Orbiter Note Added: 0000986
2015-01-12 01:09 Orbiter Status new => resolved
2015-01-12 01:09 Orbiter Resolution open => fixed
2015-01-12 01:09 Orbiter Assigned To => Orbiter


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker