YaCy-Bugtracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000504YaCy[All Projects] Generalpublic2014-11-20 16:002014-12-09 13:17
ReporterFlow 
Assigned ToOrbiter 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusfeedbackResolutionreopened 
ETAnone 
PlatformOSOS Version
Product VersionYaCy 1.8 
Target VersionFixed in Version 
Summary0000504: Starting yacy installed dia debian packaged over "/etc/init.d/yacy start" fails because /var/lib/yacy has wrong permissions
DescriptionI've just made a new install of yacy via http://www.yacy-websuche.de/wiki/index.php/En:DebianInstall [^] after 'dpkg --configure' was done, yacy failed to start first because a JRE6 was active and then because /var/lib/yacy had the wrong permissions. I'm not sure if the first failed start because of a JRE6 is a trigger in this regard.

Yacy was able to start after

chown -R yacy /var/lib/yacy

The error messages of the failed start where something along "Could not create log file"
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000977)
Orbiter (manager)
2014-12-08 12:08

not a bug, YaCy 1.8 needs JRE 1.7
(0000978)
Flow (reporter)
2014-12-09 13:17

I'm sorry I had to reopen the issue, because it's the only way to leave a reply.

I don't think that this is a JRE6 issue. As I wrote, it *may* could have been triggered by using a JRE6 at first. But everything else that causes the first start of yacy to fail tirggers this. The fact that the init script could leave the yacy installations in an inconsistent state where it's not possible to (re-)start yacy without issuing another command (chown), is the real bug. Which is what this issue report tried to address.

- Issue History
Date Modified Username Field Change
2014-11-20 16:00 Flow New Issue
2014-12-08 12:08 Orbiter Note Added: 0000977
2014-12-08 12:08 Orbiter Status new => closed
2014-12-08 12:08 Orbiter Assigned To => Orbiter
2014-12-08 12:08 Orbiter Resolution open => fixed
2014-12-09 13:17 Flow Note Added: 0000978
2014-12-09 13:17 Flow Status closed => feedback
2014-12-09 13:17 Flow Resolution fixed => reopened


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker