YaCy-Bugtracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000415YaCy[All Projects] Generalpublic2014-06-17 05:582014-09-13 16:44
Reportersmokingwheels 
Assigned ToOrbiter 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
StatusresolvedResolutionwon't fix 
ETAnone 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000415: read past EOF: RAMInputStream(name=_br6.cfs)
DescriptionLeft YaCy running overnight no load tests. Error msg flooded thru logs.
Had unloaded from memory.
Going thru event logs some updater services seem to be starting to oftern for my liking.
I have disabled Adobe Flash Player updater and Google software updater from running. See what happens now.
Additional InformationW 2014/06/17 00:59:13 net.yacy.cora.federate.solr.connector.SolrServerConnector DocListSearcher: no response for query '{!raw f=id}tzT7pUrLi9nB'
W 2014/06/17 00:59:13 net.yacy.cora.federate.solr.connector.SolrServerConnector DocListSearcher: no response for query '{!raw f=id}voaNs0hlApsb'
W 2014/06/17 00:59:13 net.yacy.cora.federate.solr.connector.SolrServerConnector DocListSearcher: no response for query '{!raw f=id}vEjTrzxsw-tQ'
E 2014/06/17 00:59:13 org.apache.solr.core.SolrCore java.io.EOFException: read past EOF: RAMInputStream(name=_br6.cfs)
    at org.apache.lucene.store.RAMInputStream.switchCurrentBuffer(RAMInputStream.java:94)
    at org.apache.lucene.store.RAMInputStream.readBytes(RAMInputStream.java:77)
    at org.apache.lucene.store.DataInput.readBytes(DataInput.java:82)
    at org.apache.lucene.store.Directory$SlicedIndexInput.readInternal(Directory.java:311)
    at org.apache.lucene.store.BufferedIndexInput.refill(BufferedIndexInput.java:271)
    at org.apache.lucene.store.BufferedIndexInput.readByte(BufferedIndexInput.java:51)
    at org.apache.lucene.store.DataInput.readVInt(DataInput.java:120)
    at org.apache.lucene.store.BufferedIndexInput.readVInt(BufferedIndexInput.java:218)
    at org.apache.lucene.codecs.BlockTreeTermsReader$FieldReader$SegmentTermsEnum$Frame.loadBlock(BlockTreeTermsReader.java:2405)
    at org.apache.lucene.codecs.BlockTreeTermsReader$FieldReader$SegmentTermsEnum.seekExact(BlockTreeTermsReader.java:1734)
    at org.apache.lucene.index.TermContext.build(TermContext.java:95)
    at org.apache.lucene.search.TermQuery.createWeight(TermQuery.java:165)
    at org.apache.lucene.search.IndexSearcher.createNormalizedWeight(IndexSearcher.java:684)
    at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:297)
    at org.apache.solr.search.SolrIndexSearcher.getDocListNC(SolrIndexSearcher.java:1609)
    at org.apache.solr.search.SolrIndexSearcher.getDocListC(SolrIndexSearcher.java:1397)
    at org.apache.solr.search.SolrIndexSearcher.search(SolrIndexSearcher.java:478)
    at org.apache.solr.handler.component.QueryComponent.process(QueryComponent.java:461)
    at org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:218)
    at org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:135)
    at net.yacy.cora.federate.solr.connector.EmbeddedSolrConnector.query(EmbeddedSolrConnector.java:212)
    at net.yacy.cora.federate.solr.connector.EmbeddedSolrConnector$DocListSearcher.<init>(EmbeddedSolrConnector.java:369)
    at net.yacy.cora.federate.solr.connector.EmbeddedSolrConnector.getMetadata(EmbeddedSolrConnector.java:410)
    at net.yacy.cora.federate.solr.connector.MirrorSolrConnector.getMetadata(MirrorSolrConnector.java:417)
    at net.yacy.cora.federate.solr.connector.ConcurrentUpdateSolrConnector.getMetadata(ConcurrentUpdateSolrConnector.java:260)
    at net.yacy.search.index.Fulltext.getLoadTime(Fulltext.java:496)
    at transferRWI.respond(transferRWI.java:237)
    at sun.reflect.GeneratedMethodAccessor38.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.yacy.http.servlets.YaCyDefaultServlet.invokeServlet(YaCyDefaultServlet.java:652)
    at net.yacy.http.servlets.YaCyDefaultServlet.handleTemplate(YaCyDefaultServlet.java:808)
    at net.yacy.http.servlets.YaCyDefaultServlet.doGet(YaCyDefaultServlet.java:314)
    at net.yacy.http.servlets.YaCyDefaultServlet.doPost(YaCyDefaultServlet.java:376)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:544)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:199)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
    at net.yacy.http.CrashProtectionHandler.handle(CrashProtectionHandler.java:33)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
    at org.eclipse.jetty.server.Server.handle(Server.java:462)
    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:279)
    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:534)
    at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:536)
    at java.lang.Thread.run(Unknown Source)

TagsNo tags attached.
Attached Files7z file icon EOFException read past EOF LOG.7z [^] (58,605 bytes) 2014-06-17 05:58

- Relationships

-  Notes
(0000895)
Orbiter (manager)
2014-09-13 16:44

not reproducible. This bug is inside of solr. Even if it appears again we cannot do anything about it because this is inside an external library. We recently changed error handling on that module which should catch a repsonse error like this but there is pretty nothing anyone in the YaCy project can do about that.

- Issue History
Date Modified Username Field Change
2014-06-17 05:58 smokingwheels New Issue
2014-06-17 05:58 smokingwheels File Added: EOFException read past EOF LOG.7z
2014-09-13 16:44 Orbiter Note Added: 0000895
2014-09-13 16:44 Orbiter Status new => closed
2014-09-13 16:44 Orbiter Assigned To => Orbiter
2014-09-13 16:44 Orbiter Resolution open => won't fix
2014-09-13 16:44 Orbiter Status closed => resolved


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker