YaCy-Bugtracker - YaCy
View Issue Details
0000763YaCy[All Projects] Generalpublic2017-07-16 22:402017-11-11 19:03
aexl 
 
normalminoralways
newopen 
none 
YaCy 1.9 
 
0000763: apt-get update says "The following signatures were invalid: 8BD752501CB62448A30EA3EA1F968B3903D886E7"
Hi,
when I try to apt-get update I get
[code]
Ign:1 http://debian.yacy.net [^] ./ InRelease
Hit:2 http://debian.yacy.net [^] ./ Release
Err:3 http://debian.yacy.net [^] ./ Release.gpg
  The following signatures were invalid: 8BD752501CB62448A30EA3EA1F968B3903D886E7
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://debian.yacy.net [^] ./ Release: The following signatures were invalid: 8BD752501CB62448A30EA3EA1F968B3903D886E7
W: Failed to fetch http://debian.yacy.net/./Release.gpg [^] The following signatures were invalid: 8BD752501CB62448A30EA3EA1F968B3903D886E7
W: Some index files failed to download. They have been ignored, or old ones used instead.
[/code]

I get this error since I upgraded from Debian 8 (stable) to 9 (stable).
Best
Followed installation instructions here http://www.yacy-websuche.de/wiki/index.php/En:DebianInstall [^]
Let YaCy run since fall 2016
# apt-get update
No tags attached.
Issue History
2017-07-16 22:40aexlNew Issue
2017-10-02 21:14henningbNote Added: 0001477
2017-10-02 22:01henningbNote Added: 0001478
2017-10-07 13:42Raphi111Note Added: 0001484
2017-10-20 12:16mantunesNote Added: 0001488
2017-10-21 10:03lucNote Added: 0001489
2017-11-10 11:19YetroNote Added: 0001491
2017-11-11 19:03lucNote Added: 0001492

Notes
(0001477)
henningb   
2017-10-02 21:14   
Hello,
i have the same problem in the same situation (dist-upgrade debian 8 to 9)

regards
henning
(0001478)
henningb   
2017-10-02 22:01   
scheint ein apt-key Problem zu sein.

Prüfung von Release.gpg mit gnupg bezogen auf die Datei Release ergibt eine ordentliche Signatur.

Löschen in apt-key und erneuerter Import bringt keine Änderung; ebensowenig der Import in Gnupg
(0001484)
Raphi111   
2017-10-07 13:42   
I have the same problem trying to install Yacy for the first time.
(0001488)
mantunes   
2017-10-20 12:16   
I also suffer from the same issue.
Is there any shortcut to install yacy?
(0001489)
luc   
2017-10-21 10:03   
Waiting for an upgrade of the repository GPG signing key, you can still manually install the Debian package (as with any other Debian package).
 - simply download the file at http://debian.yacy.net/binary/yacy_1.91.9442_all.deb [^]
 - as root, run dpkg -i /yourpath/yacy_1.91.9442_all.deb
 - that's all!
(0001491)
Yetro   
2017-11-10 11:19   
Same problem

I can't install Yacy in Debian stable, following Yacy instructions.

I can't believe this:
Severity minor (Yacy doesn't install¡)
Priority normal (It's a minor problem)
Reproducibility always (Evident)
Status new (Date Submitted: tree mounths ago)

Congratulations
(0001492)
luc   
2017-11-11 19:03   
As I also mentionned on the related GitHub issue (https://github.com/yacy/yacy_search_server/issues/124 [^]) I have set up an alternative Debian repository on JFrog Bintray to distribute YaCy developer releases (including recent changes made after the latest stable official 1.92/9000 release).

Until Orbiter finds some time to upgrade the official YaCy repository, I hope this can be useful for those who prefer to use the convenience of a Debian repository (which I understand) instead of manually downloading and installing the package.

I rewrite here the instructions to use the alternative JFrog repository :
 - as root :
  - install the Bintray GPG key :
wget -qO - https://bintray.com/user/downloadSubjectPublicKey?username=bintray [^] | apt-key add -
  - add the developer repository to your repositories, for example in a yacy.list file :
echo "deb https://dl.bintray.com/luccioman/yacy_search_server [^] stretch main" > /etc/apt/sources.list.d/yacy.list
  - update with apt :
apt-get update
  - install yacy :
apt-get install yacy

Note for an eventual upgrade from YaCy 1.92/9000 : authentication method changed from Basic HTTP to Digest HTTP (see default configuration file /usr/share/yacy/defaults/web.xml). This makes the password encoding different : so when upgrading from YaCY version 1.92.9000 or lower, please run 'dpkg-reconfigure yacy' after the upgrade to enter again and thus re-encode your YaCy administrator password.